AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920
AUSDOM -2021 PAPALOOK PA920

Ausdom

AUSDOM -2021 PAPALOOK PA920

Regular price $99.00
Unit price  per 

  • 【Ultra HD 2K Business Webcam】The PA920 USB Webcam delivers Quad HD 2K quality conference experience at resolutions up to 2952x1944p 30fps. Wide 90° viewing angle. Great for Online Chatting, Live Streaming, and Video Calling.
  • 【Superior Stereo Audio】Thanks to Built-in dual noise reducing microphones, capturing your voice from every angle, ensure clear and natural sound recording. It's the best choice of the video conference webcam. Zoom button makes it easy to zoom the size as you need, confirm the best meeting experience.
  • 【Adjustable field of view】PA920 supports the 5X digital magnification function. Adjusting the field of view to just focus on what you want via digital zoom function while maintaining UHD resolution. Provides you with more professional course teaching or presentation experience.
  • 【Removable Link Cable and Built-in Privacy Cover】papalook PA920 webcam is compatible with USB-A as well as USB-C input ports, and the USB-C (webcam end) to USB-A (computer end) link cable can be removed so you can use a longer one you have. The built-in privacy Cover plays an important role when it is not in use and prevents web hackers from Spying on you. It is perfect to provide privacy, security, and protect the lens from the dirt.
  • 【Plug and Play & Versatile Placement】No need to install drivers. Simply connect this 2K webcam to your computer by USB port. Then you can use video software such as Skype for calling; This HD streaming webcam comes equipped with a versatile tripod. You can mount the USB streaming camera on your LCD screen, notebook, table top or on your tripod. work with Windows XP / 7/ 8 / 10 or updated version, Mac OS 10.6 or updated version, Support Chrome OS, Android v5.0 or above.